Author Topic: Config issue - Wheels and pedals don't work at the same time  (Read 810 times)

aa82

  • Newbie
  • *
  • Posts: 2
    • View Profile
Config issue - Wheels and pedals don't work at the same time
« on: April 22, 2017, 01:05:46 AM »
Hi, I've just installed the demo and can't configure it to accept both wheel and pedals together.
Wheel: Thrusmaster T300RS
Pedals: Fanatec Clubsport V2
They are on separate inputs (USB)

Within the configuration menu, I can calibrate each one and assign steering to the wheel and brake/gas to the pedals correctly. However, when I calibrate/assign the pedals, the steering goes away. So I go ahead and recalibrate the wheel and at that point I lose the pedals. Seems like I just can't have both working at the same time.

Another weird thing is that under calibration -> controller sometimes I see just 2, some other times they duplicate up to 5 times (10 devices in total)...however doesn't matter what I select, it always shows as either J2 (steering) or J1 (pedals)

Can you help me understand how to fix it? Is it just an issue with the demo or should I expect the same issues in the full version?

3rd.Rail

  • Newbie
  • *
  • Posts: 47
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #1 on: April 22, 2017, 02:43:57 AM »
Can you post screen shots or phone pics of these problems?

aa82

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #2 on: April 23, 2017, 03:10:09 AM »
Ok this is what's driving me insane...I really hope somebody can help me out with this

Step 1: I check that both pedals and wheel work gas, brake, steering side to side. Everything's OK
http://imgur.com/U3c7zIA
http://imgur.com/jjTlqxB


Step 2: lauch KartRacing Pro and go to settings. You can see pedals are setup and work (see the two bars to the bottom right green and red, I was pressing the pedals). Wheel is unassigned
http://imgur.com/KLhUZqY


Step 3: I calibrate the wheel. All ok, I can find it in the list and the bar moves.
http://imgur.com/zG0kSCt


Step 4: The wheel works (see the yellow bar) but pedals are now dead.
http://imgur.com/5coFZvK


Step 5: I calibrate the pedals...notice now I've got a new set of peripherals.
http://imgur.com/QxqdEZy

Step 6: Pedals now work fine, but wheel is dead.
http://imgur.com/aU7gwDV

Step 7: I calibrate the wheel and I notice another set of peripherals is added. Nevermind, I calibrate and assign, works but now pedals don't and the loop goes on and on
http://imgur.com/6WDqb01
« Last Edit: April 23, 2017, 03:15:01 AM by aa82 »

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1847
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #3 on: April 23, 2017, 12:18:33 PM »

Thank you for the detailed report.
This issue is under investigation.

genorimo

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #4 on: May 10, 2017, 09:59:30 AM »
good morning,
I have the same problem with my base fanatec csw v2 and
my pédalier fanatec separated in the software of demonstration,
I wait for an answer to this problem to buy this product,
warmly,
gt

slicing360

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #5 on: July 14, 2017, 02:34:45 PM »
Hi,

Was this issue ever resolved? I am having the same problem.

Logitech Driving Force GT
Fanatec CSR Elite Pedals

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1847
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #6 on: July 14, 2017, 05:06:54 PM »
Hi,

Was this issue ever resolved? I am having the same problem.

Logitech Driving Force GT
Fanatec CSR Elite Pedals

Please upload the file "calib.txt", that should be saved in "My Documents"/PiBoSo/Kart Racing Pro/profiles/"your profile name"/

slicing360

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #7 on: July 15, 2017, 05:11:42 AM »
I have uploaded it as an attachment here.

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1847
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #8 on: July 15, 2017, 07:27:03 PM »
I have uploaded it as an attachment here.

Thank you.
Why is the steering wheel not calibrated?
Are you using the latest version of Kart Racing Pro, release1?

slicing360

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #9 on: July 15, 2017, 08:38:19 PM »
I'm using the release from Steam. I'm assuming this is release 1.

I've calibrated the wheels and the pedals multiple times but it will only register one or the other at any given time it seems.

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1847
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #10 on: July 15, 2017, 08:41:41 PM »

Ok.
Thank you.

Pelice

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #11 on: July 20, 2017, 08:26:55 PM »
i have the same problem with the same hardware.
yesterday works perfect with the release 1 downloaded.
today i've installed the steam version and the problem starts.


Pelice

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #12 on: July 22, 2017, 10:57:30 AM »
i've solved editing the calib.txt file in the Fanatec pedal section:

FANATEC USB Pedals
4
3
1023
0
1023
4
1023
0
1023
5
1023
0
1023
6
255
255
255
}


now all works fine!

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1847
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #13 on: July 22, 2017, 08:03:56 PM »
i've solved editing the calib.txt file in the Fanatec pedal section:

FANATEC USB Pedals
4
3
1023
0
1023
4
1023
0
1023
5
1023
0
1023
6
255
255
255
}


now all works fine!

Thank you for the report.

Vargs

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: Config issue - Wheels and pedals don't work at the same time
« Reply #14 on: July 23, 2017, 04:13:52 AM »
i have v2 fanatec wheel v2 pedals and thrustmaster shifter and wheel kinda works really sensitive in calibration but pedals not working get pedals working then wheel wont then it only turns left  and pedals wont work keep going into calibration but each trime i do it uncalibrates or unassigns the previous thing i just did think that this is the game will not support multiple usb ports yet please confirm or not really love my racing and its really frustrating this is only game my rig has issues with
cheers