• Welcome to Kart Racing Pro Official Forum. Please login or sign up.
 
April 20, 2019, 08:35:23 pm

News:

Please read the FORUM RULES


multi-monitor

Started by PiBoSo, May 23, 2011, 03:30:11 pm

Previous topic - Next topic

PsyMan

Just trying to convince a neigbour to buy this, he has a triple monitor setup using hydravision, I will report back when I have him up and running. (FSX is great on his setup)

veilsidebr

Hello Piboso,

I tried changing the core.ini file to:

[HACKS]
ColorMipMaps = 0
NoPBuffer = 0
NoRenderToTexture = 0
NoPBO = 0
NoFBO = 0
NoHDR = 1

[windows]
compatibility=1


[display]
monitor=0
setup=monitors.cfg



The monitors.cfg file to the settings bellow:

primary
{
   screen_distance = 600
   screen_width = 710
   screen_height = 400
   width = 740
   height = 430
}

global
{
   angle_x = 32
}

monitor0
{
   display = 1
        pos_x = -1
   res_x = 1920
   res_y = 1080
   bpp = 32
        multisample = 4
}

monitor1
{
   display = 2
   pos_x = 1
   res_x = 1920
   res_y = 1080   
        bpp = 32
        multisample = 4
}


Still i cannot enter the game properly. It stays all black upon double click, when i do an ALT+TAB and return to game later, i can see the image but after any clicks it returns to windows, so i cannot enter the game properly.

I tried, before changing files above, to set the triple screen resolution i generally use and set the aspect ratio to "resolution" but the game crashes with the bellow error:

---------------------------
NVIDIA OpenGL Driver
---------------------------
Your hardware configuration does not meet minimum specifications
needed to run the application. The application must close.
Error code: 6
Would you like to visit http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3008 for help?

Any ideas on?

PiBoSo

Quote from: veilsidebr on January 04, 2013, 10:07:12 pm
Still i cannot enter the game properly. It stays all black upon double click, when i do an ALT+TAB and return to game later, i can see the image but after any clicks it returns to windows, so i cannot enter the game properly.

I tried, before changing files above, to set the triple screen resolution i generally use and set the aspect ratio to "resolution" but the game crashes with the bellow error:

---------------------------
NVIDIA OpenGL Driver
---------------------------
Your hardware configuration does not meet minimum specifications
needed to run the application. The application must close.
Error code: 6
Would you like to visit http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3008 for help?

Any ideas on?


Please try upgrading the graphics drivers to the latest official ones.

DjFIL

March 13, 2013, 04:35:34 pm #33 Last Edit: November 16, 2013, 08:48:34 pm by DjFIL
Nice.  Got it working more or less.  I'm using mis-matched monitors for now.  Middle is 24" 16:9 (set to 1600x1024 for triple screen games, to match side screens height) and sides are 19" 4:3 (at 1280x1024).

My monitors.cfg (currently)
primary
{
screen_distance = 711
screen_width = 533
screen_height = 298
width = 572
height = 343
}

global
{
angle_x = -10
}

monitor0
{
display = 2
        pos_x = -1
res_x = 1280
res_y = 1024
bpp = 32
        multisample = 4
}

monitor1
{
display = 0
pos_x = 1
res_x = 1280
res_y = 1024
        bpp = 32
        multisample = 4
}


In the core.ini I did have to adjust "monitors=2" to get it working.  My monitors (in windows config) are setup as 3/2/1 (from left to right).

Got my bezel correction looking great now... but funny enough, I had to set "angle_x = -10"... even though I got a protractor out and can confirm my monitors are at 30 degrees each.

(EDIT: pictures no longer hosted)

Now how can I get FOV to go above 85?  In iRacing I'm using 115 to 120 degrees for FOV.

PiBoSo

Quote from: DjFIL on March 13, 2013, 04:35:34 pm
Nice.  Got it working more or less.  I'm using mis-matched monitors for now.  Middle is 24" 16:9 (set to 1600x1024 for triple screen games, to match side screens height) and sides are 19" 4:3 (at 1280x1024).

My monitors.cfg (currently)
primary
{
screen_distance = 711
screen_width = 533
screen_height = 298
width = 572
height = 343
}

global
{
angle_x = -10
}

monitor0
{
display = 2
        pos_x = -1
res_x = 1280
res_y = 1024
bpp = 32
        multisample = 4
}

monitor1
{
display = 0
pos_x = 1
res_x = 1280
res_y = 1024
        bpp = 32
        multisample = 4
}


Now how can I get FOV to go above 85?  In iRacing I'm using 115 to 120 degrees for FOV.


FOV is automatically calculated based on the provided data, in particular "screen_distance".

DjFIL

Quote from: PiBoSo on March 13, 2013, 05:53:05 pm
FOV is automatically calculated based on the provided data, in particular "screen_distance".


So if I make the screen_distance larger?  Or smaller?  I thought I had it right, but it doesn't look right.  Have to tilt camera down too much.  Want to barely see the top edge of the virtual wheel (to match how I see my wheel in relation to the screen).

PiBoSo

Quote from: DjFIL on March 13, 2013, 06:30:54 pm
Quote from: PiBoSo on March 13, 2013, 05:53:05 pm
FOV is automatically calculated based on the provided data, in particular "screen_distance".


So if I make the screen_distance larger?  Or smaller?  I thought I had it right, but it doesn't look right.  Have to tilt camera down too much.  Want to barely see the top edge of the virtual wheel (to match how I see my wheel in relation to the screen).


A shorter distance should give more FOV, but it wouldn't be realistic if it doesn't roughly match the real distance from the main monitor to the eyes.

DjFIL

Thanks again for the help.  Got it working really well.  But wow... big frame rate hit, more so then most other games that I currently have working in triple screen.  Was 150-180 when at 1920x1080 with everything at maximum (only 3D grass disabled)... now 45-70 (with lowered AA and AF) on 4360x1024.  And I did try "NoPBO=0"

But overall works great.  Got the FOV thing sorted out, my eyes were further back from the screen, and got a tilt angle that works for me (45 degrees)... just if I use the "tuck" feature I'm totally blind to the track ahead.  Also still using the negative for "angle_x" (now at -3), as I found it wasn't cutting the bezel correctly (and my screens are confirmed at 30 degrees each).

PiBoSo

Quote from: DjFIL on March 14, 2013, 09:27:10 pm
Thanks again for the help.  Got it working really well.  But wow... big frame rate hit, more so then most other games that I currently have working in triple screen.  Was 150-180 when at 1920x1080 with everything at maximum (only 3D grass disabled)... now 45-70 (with lowered AA and AF) on 4360x1024.  And I did try "NoPBO=0"

But overall works great.  Got the FOV thing sorted out, my eyes were further back from the screen, and got a tilt angle that works for me (45 degrees)... just if I use the "tuck" feature I'm totally blind to the track ahead.  Also still using the negative for "angle_x" (now at -3), as I found it wasn't cutting the bezel correctly (and my screens are confirmed at 30 degrees each).


Performance with three renders is a known problem. It will be improved as soon as possible.

Piers Prior

Quote from: PiBoSo on March 14, 2013, 10:40:47 pm
Quote from: DjFIL on March 14, 2013, 09:27:10 pm
Thanks again for the help.  Got it working really well.  But wow... big frame rate hit, more so then most other games that I currently have working in triple screen.  Was 150-180 when at 1920x1080 with everything at maximum (only 3D grass disabled)... now 45-70 (with lowered AA and AF) on 4360x1024.  And I did try "NoPBO=0"

But overall works great.  Got the FOV thing sorted out, my eyes were further back from the screen, and got a tilt angle that works for me (45 degrees)... just if I use the "tuck" feature I'm totally blind to the track ahead.  Also still using the negative for "angle_x" (now at -3), as I found it wasn't cutting the bezel correctly (and my screens are confirmed at 30 degrees each).


Performance with three renders is a known problem. It will be improved as soon as possible.
has it been improved yet or is it still WIP :)
The world is your lobster

PiBoSo

June 10, 2013, 08:42:41 pm #40 Last Edit: June 10, 2013, 08:53:09 pm by PiBoSo
Quote from: Hispinkness Prior on June 10, 2013, 08:16:39 pm
Quote from: PiBoSo on March 14, 2013, 10:40:47 pm
Quote from: DjFIL on March 14, 2013, 09:27:10 pm
Thanks again for the help.  Got it working really well.  But wow... big frame rate hit, more so then most other games that I currently have working in triple screen.  Was 150-180 when at 1920x1080 with everything at maximum (only 3D grass disabled)... now 45-70 (with lowered AA and AF) on 4360x1024.  And I did try "NoPBO=0"

But overall works great.  Got the FOV thing sorted out, my eyes were further back from the screen, and got a tilt angle that works for me (45 degrees)... just if I use the "tuck" feature I'm totally blind to the track ahead.  Also still using the negative for "angle_x" (now at -3), as I found it wasn't cutting the bezel correctly (and my screens are confirmed at 30 degrees each).


Performance with three renders is a known problem. It will be improved as soon as possible.
has it been improved yet or is it still WIP :)


Sorry, it hasn't been optimized yet. At the moment unfortunately there still are a lot of tasks with higher priority.

Piers Prior

Quote from: PiBoSo on June 10, 2013, 08:42:41 pm
Quote from: Hispinkness Prior on June 10, 2013, 08:16:39 pm
Quote from: PiBoSo on March 14, 2013, 10:40:47 pm
Quote from: DjFIL on March 14, 2013, 09:27:10 pm
Thanks again for the help.  Got it working really well.  But wow... big frame rate hit, more so then most other games that I currently have working in triple screen.  Was 150-180 when at 1920x1080 with everything at maximum (only 3D grass disabled)... now 45-70 (with lowered AA and AF) on 4360x1024.  And I did try "NoPBO=0"

But overall works great.  Got the FOV thing sorted out, my eyes were further back from the screen, and got a tilt angle that works for me (45 degrees)... just if I use the "tuck" feature I'm totally blind to the track ahead.  Also still using the negative for "angle_x" (now at -3), as I found it wasn't cutting the bezel correctly (and my screens are confirmed at 30 degrees each).


Performance with three renders is a known problem. It will be improved as soon as possible.
has it been improved yet or is it still WIP :)


Sorry, it hasn't been optimized yet. At the moment unfortunately there still are a lot of tasks with higher priority.
okay np :)
The world is your lobster

James Beer

 

roly

Quote from: LauZzZn on July 29, 2013, 09:36:49 pm
Quote from: LauZzZn on July 29, 2013, 08:46:02 am
hey guys, i read everything in this thread but i still dont understand how to set it up correctly.
i got a gtx 660 and one screen with resolution 1920x1080 which ist adapted with hdmi cable and 2 screens with 800x600( can be changed to another resolution until 1600x1024) which are adapted both with dvi.
could anyone help me to set them up correctly


no one ? :'(

Hi. I've 3 x BenQ (3D) with 2 x GTX 580 SLi (NVidia). It works fine. No problems.
Dont connect the monitors differently. Connect them all on DVi.
All Monitors have to be the same, also the same resolution. U can not use different monitors.
Hope that helped.   :o)
Bye, roly
TopKart - IAME-Parilla 100 Membran (1999)
TopKart Twister 2014 Rotax Max Evo 2015
Games: GTR - Project CARS 1 / 2 - KRP - RaceRoom
-------------------------------------------------------------------------------------------------------------
intel i7 - asus - 64gb -1TB ssd - nvidia gtx1080 - win10pro - Fanatec - 3 x 24" 3D - Oculus VR

DjFIL

November 16, 2013, 08:47:12 pm #44 Last Edit: November 17, 2013, 09:07:46 am by DjFIL
Just switched from my old mismatched setup, to matching 24" triple screens.  Awesome!  Just wanted to share my settings.

With nVidia Surround enabled.  In game selected my bezel corrected resolution (5890x1080).

With the monitors.cfg, I found out that I had to omit the outside monitor information, and only provide details about the middle screen.  This is likely because with nVidia Surround enabled, it reports it as one large display.  But without the monitor.cfg settings, the FOV and warp (for side screens) did not look correct.

primary
{
   screen_distance = 762
   screen_width = 533
   screen_height = 297
   width = 559
   height = 348
}

global
{
   angle_x = 30
}


Picture of the results: http://imgur.com/hRI2pA9

Updated with correct stats and a picture.