Author Topic: Thrustmaster TX nothing works (Steering now works; pedals do not)  (Read 270 times)

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Thrustmaster TX nothing works (Steering now works; pedals do not)
« on: September 14, 2017, 01:25:21 AM »
I have hooked Thrustmaster TX, pedals and shifter up and verified in Windows in Device Manager that it is listed as Game Controller.  Updated Windows 10 Nvidia 970M drivers.  Installed Thrustmaster TX drivers and calibrated.  When I start the Kart Racing Pro only the keyboard controls work for the kart; none of the steering wheel or pedals work.

System:  Intel i7 2.6 GHz, 12GB RAM, Windows 10 64bit, Nvidia Geforce GTX 970M
Controls:  Thrustmaster TX base, 599XX Evo 30 wheel, T3PA-Pro pedals

Thanks in advance to anyone who can assist me.
« Last Edit: September 15, 2017, 05:13:59 AM by blew »

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1845
    • View Profile
    • Email
Re: Thrustmaster TX nothing works
« Reply #1 on: September 14, 2017, 08:44:35 PM »

Please report if this quick guide is useful:
http://forum.kartracing-pro.com/index.php?topic=3596.0

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works
« Reply #2 on: September 15, 2017, 04:59:58 AM »
Thank you PiBoSo, the steering is now is working.  The pedals still do not work.  In Windows 10, I have calibrated the pedals by pushing on each, and it the green bar showed that pedals were working.  In Kart Racing Pro, I went to Settings, Controls:  Throttle still shows "Up", Brake shows "Down".  When I click on Throttle, the popup box says "Unassigned", as does the Brake.  Please let me know how to get the pedals to work?

Thanks in advance.

Cory_Hayes

  • Hero Member
  • *****
  • Posts: 860
    • View Profile
Re: Thrustmaster TX nothing works
« Reply #3 on: September 15, 2017, 06:01:46 AM »
Thank you PiBoSo, the steering is now is working.  The pedals still do not work.  In Windows 10, I have calibrated the pedals by pushing on each, and it the green bar showed that pedals were working.  In Kart Racing Pro, I went to Settings, Controls:  Throttle still shows "Up", Brake shows "Down".  When I click on Throttle, the popup box says "Unassigned", as does the Brake.  Please let me know how to get the pedals to work?

Thanks in advance.

I know this sounds dumb, but where it says " Unassigned " you clicked on it then pushed your pedal in, right?

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #4 on: September 15, 2017, 08:51:47 AM »
Thanks Cory.  Yes I tried that.

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1845
    • View Profile
    • Email
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #5 on: September 17, 2017, 09:31:24 PM »
Thanks Cory.  Yes I tried that.

Have you calibrated the pedals in Kart Racing Pro, like you did for the steering wheel?
All inputs must be calibrated at the same time.

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #6 on: September 17, 2017, 10:01:34 PM »
Yes I calibrated the pedals in Kart Racing Pro, at same time as the steering wheel.  I even saw calibration working for X and Y when I pushed throttle and brake.  However, when you view the Input screen where it shows calibration, the throttle still shows "Up arrow" and brake shows "Down arrow", and if I click on each, they say "Unassigned". As a result, only the keyboard works for throttle and brake.

How can I get the pedals to be "Assigned" to Kart Racing Pro calibration?

Thanks

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1845
    • View Profile
    • Email
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #7 on: September 18, 2017, 10:24:30 PM »

Have you pressed the throttle pedal when the "Throttle" dialog with the "Unassigned" state appears?

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #8 on: September 21, 2017, 08:31:51 PM »
Yes I have pressed throttle when unassigned appears.  I have also pressed throttle when calibrating steering wheel...when I have done this the calibration screen shows number calibration for both throttle and brake, but when I save this the Input page still shows throttle "up" and brake "down".  This indicates the keyboard up and down keys are the only controls that work.  when I go to Input screen and click on throttle...it shows "unassigned" which is shaded and I cannot click on it to assign pedals.

Appreciate your assistance.

PiBoSo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1845
    • View Profile
    • Email
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #9 on: September 22, 2017, 09:24:27 PM »

There is no need to click on the "unassigned" text.
When the dialog appears, pressing the throttle pedal should automatically assign it.

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #10 on: September 24, 2017, 06:15:07 PM »
Thank you!!!  Everything is now working! 

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #11 on: September 26, 2017, 12:44:40 AM »
Well I have another problem....we wanted to reroute wires so disconnected hdmi and usb cables.  When we reconnected everything, the kart does not move.  You can see the steering wheel move and throttle/brake work on the screen, but the kart doesn't go anywhere.

We went through the calibration of steering wheel and pedals again and that process worked.

Any ideas would be appreciated!!

Cory_Hayes

  • Hero Member
  • *****
  • Posts: 860
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #12 on: September 26, 2017, 04:02:52 AM »
....Have you pressed the " starter " button to turn the kart on?
Or pressed the " push " button to push start the KZ1 or F100

+ Go into settings and the tab all the way to the right ( I believe its the simulation tab or something, turn on automatic idle.

blew

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Thrustmaster TX nothing works (Steering now works; pedals do not)
« Reply #13 on: September 27, 2017, 07:28:17 AM »
Thanks Cory.  Will try tomorrow.