• Welcome to Kart Racing Pro Official Forum. Please login or sign up.
 
October 24, 2019, 06:36:45 am

News:

Please read the FORUM RULES


Steering wheel setup

Started by PiBoSo, November 12, 2013, 02:11:13 pm

Previous topic - Next topic

PiBoSo

November 12, 2013, 02:11:13 pm Last Edit: October 25, 2017, 05:14:33 pm by PiBoSo
It is important to correctly setup the steering wheel.

1 ) In the steering wheel profiler, disable the centering spring and damping, or at least let the software override them.
2 ) Take note of the rotation ( the suggested value is 180 ).
3 ) Start Kart Racing Pro and click on Settings -> Input -> Calibration.
4 ) Move all the inputs to their full extent.
5 ) If you have other controllers connected as a separate device, select them from the dropdown menu at the top of the calibration screen.
6 ) Repeat from 4) until all controllers have been calibrated at the same time
7 ) Then leave all inputs of all controllers perfectly centered / released before pressing "Ok".
8 ) Click on the right of Controls -> Steer and steer LEFT to assign the control.
9 ) Under Advanced -> Steer, set deadzone to 0, linearity to 100 and leave smooth unchecked.
10 ) Enable force feedback and set strength to 100%, deadzone to 0% and linearity to 100%
11 ) Enable wheel rotation and set it directly or use the wizard. In both cases the value should match the rotation set in the profiler.

12 ) If you are experiencing vibration on straights, please try increasing force feedback deadzone in steps of 5. This shouldn't be needed on the Logitech G25 and G27.
13 ) If you feel the force in the center is a bit weak, you can try lowering the force feedback linearity.

This is how the FF curve looks like at 0 ( top ) and 100 ( bottom ) linearity:

AscendingDrive

9 ) If you feel the force in the center is a bit weak, you can try lowering the force feedback linearity.

This solved all my problems with the game. thanks!

rt45433

Hi there. do you have any advice for setting up a Thrustmaster t500rs, when i follow the instructions above to set it to 180 degrees and do a lock to lock on the wheel in the game calibration it feels like i have to turn the wheel a bigger distance to turn to same distance in the game. What i have tried to do is set the wheel up so if i turn the wheel 90 degrees to the right(my left hand is directly at the top of the wheel) and this then matches the hand on the wheel in the game. would this be a good way to set it up of does anyone who is using the T500rs have a better way?


7HUND3R

I notice that the addresseed is not like before, turning a bit and makes u Kart abrupt. I have a g27

I resolved not following this tutorial.

dibu

April 06, 2015, 07:22:55 pm #4 Last Edit: April 06, 2015, 07:25:12 pm by dibu
Quote from: 7HUND3R on April 06, 2015, 06:53:35 pm
I notice that the addresseed is not like before, turning a bit and makes u Kart abrupt. I have a g27

I resolved not following this tutorial.

Here my G27 settings for Logitech Profiler and KRP:
http://forum.kartracing-pro.com/index.php?topic=5130.msg39778#msg39778
They still work well for KRP beta13b.

If the kart still turns too sharp when steering, lower "Caster" to e.g 17. If you have too much oversteer, you can try
to decrease the "Track width" at the rear axle.

PDR

Months ago i was able to use my Driving Force GT wheel very well. Now with 13b i cant.. Dont know why.. my wheel goes crazy like right left right left its like being possessed.. If i turn in game settings force feedback off this problem dissapears. But i want force feedback. I use all settings just like PiBoSo but it inst worrking as suposed.
In settings menu under force feedback i have tried everything.. Increase/decrease of force feedback linearity and deadzone with mixed possibilities and lots of diverent values but still goes crazy..
What can be the problem??

dibu

Quote from: PDR on May 03, 2015, 12:37:40 am
Months ago i was able to use my Driving Force GT wheel very well. Now with 13b i cant.. Dont know why.. my wheel goes crazy like right left right left its like being possessed.. If i turn in game settings force feedback off this problem dissapears. But i want force feedback. I use all settings just like PiBoSo but it inst worrking as suposed.
In settings menu under force feedback i have tried everything.. Increase/decrease of force feedback linearity and deadzone with mixed possibilities and lots of diverent values but still goes crazy..
What can be the problem??



Did you check the settings in your Logitech Profiler? For a first test you could use my G27 Profiler settings.
Quote from: dibu on January 10, 2015, 12:29:59 pm
Here are my settings.  Everything not mentioned (linearity, dead zone, smooth ...) is default.

Wheel:                      Logitech G27

---------
Logitech Profiler:

Overall Effects Strength:                                 100%   
Spring Effect Strength:                                   0%
Damper Effect Strength:                                   0%

Enable centering Spring in Force Feedback Games:          checked   
Centering Spring Spring Strength:                         0%

Report Combined Pedals:                                   unchecked
Degrees Of Rotation:                                      180°

Allow Game To Adjust Settings:                            checked

---------
KRP:
Settings (Input)

Force Feedback
Enable:                     checked
Strength:                   100%

Wheel Rotation
Enable:                     checked
Angle:                      180°                 



PDR

Dibu yes i checked settings on logitech profiler. And i tried with your settings (well are the same as me) and didnt worked..

Kingsberry

Quote from: PDR on May 03, 2015, 11:20:34 am
Dibu yes i checked settings on logitech profiler. And i tried with your settings (well are the same as me) and didnt worked..


Hi PDR, did you find a solution yet?

PDR

No solution.  But i dont have game or wheel now so its been like 2 years without playing.  Cant help you.

Kayk

Quote from: PiBoSo on November 12, 2013, 02:11:13 pm
It is important to correctly setup the steering wheel.

1 ) In the steering wheel profiler, disable the centering spring and damping, or at least let the software override them.
2 ) Take note of the rotation ( the suggested value is 180 ).
3 ) Start Kart Racing Pro and click on Settings -> Input -> Calibration.
4 ) Move all the inputs to their full extent.
5 ) If you have other controllers connected as a separate device, select them from the dropdown menu at the top of the calibration screen.
6 ) Repeat from 4) until all controllers have been calibrated at the same time
7 ) Then leave all inputs of all controllers perfectly centered / released before pressing "Ok".
8 ) Click on the right of Controls -> Steer and steer LEFT to assign the control.
9 ) Under Advanced -> Steer, set deadzone to 0, linearity to 100 and leave smooth unchecked.
10 ) Enable force feedback and set strength to 100%, deadzone to 0% and linearity to 100%
11 ) Enable wheel rotation and set it directly or use the wizard. In both cases the value should match the rotation set in the profiler.

12 ) If you are experiencing vibration on straights, please try increasing force feedback deadzone in steps of 5. This shouldn't be needed on the Logitech G25 and G27.
13 ) If you feel the force in the center is a bit weak, you can try lowering the force feedback linearity.

This is how the FF curve looks like at 0 ( top ) and 100 ( bottom ) linearity:


What is the "steering wheel profiler" and how do I find it on my computer
I have a Fanatec wheel and pedals and when I set the controls in settings to the wheel and pedals it will not save.

PiBoSo

Quote from: Kayk on December 01, 2017, 08:17:33 pm
I have a Fanatec wheel and pedals and when I set the controls in settings to the wheel and pedals it will not save.


Are the controller settings lost when re-launching KRP?

Endless

Quote from: PiBoSo on November 12, 2013, 02:11:13 pm
It is important to correctly setup the steering wheel.

1 ) In the steering wheel profiler, disable the centering spring and damping, or at least let the software override them.
2 ) Take note of the rotation ( the suggested value is 180 ).
3 ) Start Kart Racing Pro and click on Settings -> Input -> Calibration.
4 ) Move all the inputs to their full extent.
5 ) If you have other controllers connected as a separate device, select them from the dropdown menu at the top of the calibration screen.
6 ) Repeat from 4) until all controllers have been calibrated at the same time
7 ) Then leave all inputs of all controllers perfectly centered / released before pressing "Ok".
8 ) Click on the right of Controls -> Steer and steer LEFT to assign the control.
9 ) Under Advanced -> Steer, set deadzone to 0, linearity to 100 and leave smooth unchecked.
10 ) Enable force feedback and set strength to 100%, deadzone to 0% and linearity to 100%
11 ) Enable wheel rotation and set it directly or use the wizard. In both cases the value should match the rotation set in the profiler.

12 ) If you are experiencing vibration on straights, please try increasing force feedback deadzone in steps of 5. This shouldn't be needed on the Logitech G25 and G27.
13 ) If you feel the force in the center is a bit weak, you can try lowering the force feedback linearity.

This is how the FF curve looks like at 0 ( top ) and 100 ( bottom ) linearity:


Hi, I have a Thrustmaster T300RS and have follow your instructions on the setting.  However, the wheel keeps on turning left and right itself even when the kart stops? What setting do I need to adjust?

kasper21

Quote from: Endless on July 19, 2018, 05:53:35 pm
Quote from: PiBoSo on November 12, 2013, 02:11:13 pm
It is important to correctly setup the steering wheel.

1 ) In the steering wheel profiler, disable the centering spring and damping, or at least let the software override them.
2 ) Take note of the rotation ( the suggested value is 180 ).
3 ) Start Kart Racing Pro and click on Settings -> Input -> Calibration.
4 ) Move all the inputs to their full extent.
5 ) If you have other controllers connected as a separate device, select them from the dropdown menu at the top of the calibration screen.
6 ) Repeat from 4) until all controllers have been calibrated at the same time
7 ) Then leave all inputs of all controllers perfectly centered / released before pressing "Ok".
8 ) Click on the right of Controls -> Steer and steer LEFT to assign the control.
9 ) Under Advanced -> Steer, set deadzone to 0, linearity to 100 and leave smooth unchecked.
10 ) Enable force feedback and set strength to 100%, deadzone to 0% and linearity to 100%
11 ) Enable wheel rotation and set it directly or use the wizard. In both cases the value should match the rotation set in the profiler.

12 ) If you are experiencing vibration on straights, please try increasing force feedback deadzone in steps of 5. This shouldn't be needed on the Logitech G25 and G27.
13 ) If you feel the force in the center is a bit weak, you can try lowering the force feedback linearity.

This is how the FF curve looks like at 0 ( top ) and 100 ( bottom ) linearity:


Hi, I have a Thrustmaster T300RS and have follow your instructions on the setting.  However, the wheel keeps on turning left and right itself even when the kart stops? What setting do I need to adjust?


Try turning down your force feedback