Author Topic: g27 steering wheel bug  (Read 643 times)

Alessandro Ceronetti

  • Jr. Member
  • **
  • Posts: 56
  • Junior X30/ Junior OK Driver
    • View Profile
    • Email
g27 steering wheel bug
« on: August 26, 2016, 07:53:15 AM »
When I downloaded the new Beta15b for Kart Racing Pro, the steering wheel calibrates like it should do, it spins around 420 and calibrates. Now, here is where the problems start. (This behavior that the wheel has is now on every console, on every game that I use) The pedals need pressing for a few seconds to actually make them work properly. The power source light, (the green light on the side of the steering wheel where the H-shaped gearstick is), does not turn on. The buttons where the H-shaped gearstick don't work. What i'm suspecting, and not hoping, is that a bit of the cable is damaged inside so no power comes into the joystick part. I have checked the rubber protection of the cables, and it looks in perfect condition.    Please could somebody help as this is making impossible to play certain games. Thanks! :)
Please request for events :)

dibu

  • Hero Member
  • *****
  • Posts: 666
    • View Profile
Re: g27 steering wheel bug
« Reply #1 on: August 26, 2016, 06:24:31 PM »
Is the LED off or is it blinking after you start the PC with the wheel attached?
-If binking after initialisation there's probably a problem with the rotary sensor (mine was also broken last year).
-If completely off, the problem is more serious. External power supply, DC input circuit or shortcut inside.

Can you please describe exactly how the the wheel acts when the PC starts and what it shows in Logitech Profiler?


Alessandro Ceronetti

  • Jr. Member
  • **
  • Posts: 56
  • Junior X30/ Junior OK Driver
    • View Profile
    • Email
Re: g27 steering wheel bug
« Reply #2 on: September 07, 2016, 07:14:30 AM »
So when I plug the wheel in it rotates 420 degrees right and 420 degrees left, like it has always done. But now the pedals need pressing for a few seconds to make them work, which has never done before. So after that happens the green LED should turn on but it stays off for the whole time. I think so too that's something in the cables that's going wrong, but the strange thing is is that it's only been doing this since I got the new beta. So where the green LED is, nothing works like its not receiving any kind of power source
Please request for events :)

casasracingmotorsport

  • Full Member
  • ***
  • Posts: 138
    • View Profile
    • Email
Re: g27 steering wheel bug
« Reply #3 on: October 08, 2016, 10:17:59 AM »
i think the problem is the cable of your pedals but i am not sure