• Welcome to Kart Racing Pro Official Forum. Please login or sign up.
 
September 28, 2021, 09:04:26 PM

News:

Kart Racing Pro release12b available! :)


Controls setup question

Started by Daveroche, August 31, 2021, 07:53:35 PM

Previous topic - Next topic

Daveroche

New user.
Have a simulator with a simucube wheel and analogue throttle and brake, from Kartsim.
On the controller setup page, when I click on steering the sub menu flicks up and disappears.
Have been through the calibration routine.
It's as if one of the controls is constantly working so when I click anything it gets automatically assigned.
Any ideas?

Overdue

Have you seen the Wheel/Pedal Setup Guide in Steam?

Does your wheel and pedals show up together or separately in the "Controller Profile" dropdown?

It's been a while since I set my system up. G27 and Fanatec CSPV3 pedals. I had to do the config in a specific order or it would just delete my wheel config. Don't remember which I had to do first.

Hope this helps.
To Each Their Own

Daveroche

Thanks for your help.
I followed the steam guide
My rig is very analogue - the brake pedal is connected to a real brake caliper complete with hydraulic fluid and the brake pressure is measured there.
I think maybe the issue I am having is related to the complexity of that kind of stuff.

LXS77

Hi, that complexity doesn't really matter. If the device can work with rFactor, it can work with KRP. Can you please attach a screenshot of the Calibration window (Settings -> Input tab -> Calibration button)? What can you see there?

Daveroche

You cannot see attachments on this board.

Daveroche

Here are the calibration screenshots. The values are jumping around a lot.

Daveroche

Very short video showing what happens when I click the Steer option.

LXS77

September 06, 2021, 09:04:18 PM #7 Last Edit: September 07, 2021, 12:36:38 PM by LXS77
Quote from: Daveroche on September 04, 2021, 09:21:59 PMHere are the calibration screenshots. The values are jumping around a lot.

Hi again,

If the values in Calibration window are jumping around, it means the device hasn't been calibrated yet.

To calibrate, select Simucube and rotate the wheel left and right several times. Switch to BU0836-LC and depress the pedals fully 3-4 times. Press OK to close the Calibration and try to assign controls to Steer, Throttle and Brake.

For your reference, I've recorded a short video to illustrate the calibration process for my wheel and pedals.