• Welcome to Kart Racing Pro Official Forum. Please login or sign up.
 
June 15, 2019, 11:08:20 pm

News:

Please read the FORUM RULES


Dedicated server

Started by PiBoSo, June 19, 2010, 11:38:45 pm

Previous topic - Next topic

PiBoSo

Quote from: VELOCIPEDE on March 13, 2011, 01:24:27 pm
when i open the Drivingitalia.net dedicated server i have the rolling start, but i don't want the rolling, i want the normal standing start! Help me please.


It is not possible to set start procedure type. It is always rolling start, unless event's category is set to KS1


Schwoni


VELOCIPEDE


Schwoni

[connection]
name =Lonato Training
maxclient = 5
password =
admin_password =
bandwidth = 2 ; 0 -> low, 1 -> medium, 2 -> high
MOTD = Have fun; message of the day

[export]
results = ; 0 or 1, If set to 1 it will automatically save the full replay at the end of the race
directory = C:\Programm files\Kart racing pro\replays; the directory where results will be saved ( must exist )
units = 0 ; 0 -> metric units, 1 -> English units

[replay]
save = 1; 0 or 1, If set to 1 it will automatically save the full replay at the end of the race
directory = C:\Program Files\Kart Racing Pro\replay; the directory where replays will be saved ( must exist )

[event]
track = Lonato; track ID ( for ex. rye )
category = KC1; kart category allowed. Empty -> Open; KC1, KC3, KS1

[weather]
realistic = 0; 0 or 1, if set to 1, following params are ignored
conditions = 0; 0 -> sunny, 1 -> cloudy, 2 -> rainy
temperature = 38; air temperature, celsius
wind_direction = 0; 0 -> north, 1 -> north-east, 2 -> east, ..., 7 -> north-west
wind_speed = 0; meters/second

[hardcore]
force_cockpit = 1; 0 or 1
no_aids = 1; 0 or 1

[race]
quick_race = 1; 0 or 1, if set to 1, practice, sighting lap and warmup lap are skipped
practice_length = 30; minutes
qualify_length = 20; minutes
sighting_lap = 0; 0 or 1
warmup_lap = 0; 0 or 1
race_length = 20; % of full length


This is my dedicated.ini but when i start the server in wodow only is:
Session name: dedicatedSession
Max clients: 20
Bandwidth: low
==============================
Track: amay
Category: Open
Practice: 20 min
Qualify: 20 min
Race: 10%
Realistic weather


Whats the matter?

Schwoni

the server work but not with my values. wrong track, name, maxclients, category.
is it right to crate dedicated.ini with a editor and save this text and only to call it dedicated.ini.
when not please explain me how to create it right.

Schwoni

Ja Dateityp: : Textdokument (.txt)

Yes filename is Dedicated.ini and in properties in filetype: .txt

Schwoni

Ok thank you this fix it :)

aireisor

I still don't understand where and how I set these ports? Can somebody explain please?

Aritz

Piboso:

We are testing dedicated server for the 1st KRP league and we need some time recording system but if I activate "replay" and "results" options, only if the race finishes are replays and results...

Can you make that peoples best times can be recorded? Then we will be able to organize pilots using their best times made the day before of the race IN the server (we can controle them)

Thank you

Schwoni

Hi guys,
Is there a way to start a server with kart class only kc3 and kc1 ??
i don`t wanna to have shifters there.

PiBoSo

Quote from: Schwoni on April 19, 2011, 05:17:53 pm
Hi guys,
Is there a way to start a server with kart class only kc3 and kc1 ??
i don`t wanna to have shifters there.


No. It's not possible.

VELOCIPEDE

the dedicated server work perfectly, but after a race don't restart and close without message

PiBoSo

Quote from: VELOCIPEDE on April 27, 2011, 03:46:46 pm
the dedicated server work perfectly, but after a race don't restart and close without message


Is this the same problem reported here: http://forum.kartracing-pro.com/index.php?topic=309.0 ?
The problem should be fixed in Beta3.

SRL-Hitman

Hello I have a dedicated server that I run GTR2 on and I am trying to get KRP to run on it with no luck keeps crashing.
The machine is running XP with service pack2.
I have setup a ded server on my work PC with no issues and works fine.
This server has limited graphics capability but would not think that the server window would be an issue.
All I get when I launch the icon is a larger black window then the windows error box.
Has anyone else had this issue......any help would be appreciated!

Thanks, Hitman.

PiBoSo

Quote from: SRL-Hitman on May 11, 2011, 05:55:05 pm
Hello I have a dedicated server that I run GTR2 on and I am trying to get KRP to run on it with no luck keeps crashing.
The machine is running XP with service pack2.
I have setup a ded server on my work PC with no issues and works fine.
This server has limited graphics capability but would not think that the server window would be an issue.
All I get when I launch the icon is a larger black window then the windows error box.
Has anyone else had this issue......any help would be appreciated!

Thanks, Hitman.


Could you please post the error message?
The only requirement of dedicated server should be the installation of OpenAL redist.