• Welcome to Kart Racing Pro Official Forum. Please login or sign up.
 
September 26, 2020, 11:07:03 PM

News:

Please read the FORUM RULES


drive online on DrivingItalia server

Started by VELOCIPEDE, January 06, 2012, 08:58:20 PM

Previous topic - Next topic

VELOCIPEDE

you can view, enter and drive online into the Drivingitalia dedicated server?
all ok without problem?

laraarsa


Aritz

Neither do I...

When creating a server, you should use only UDP ports, do you?

VELOCIPEDE

but you view the server? you can enter and drive online?
i have set "kart.exe -dedicated 10600 -set params dedicated.ini"
port 10600 is not correct? i have to use another port?
this is my ini file

Quote[connection]
name =DrivingItalia.NET
maxclient =20
password =
admin_password =puzzola
bandwidth =2 ; 0 -> low, 1 -> medium, 2 -> high
max_ping =
MOTD =www.drivingitalia.net ; message of the day

[export]
results =0  ; 0 or 1, If set to 1 it will automatically export results at the end of the race
directory = ; the directory where results will be saved ( must exist )
units =0  ; 0 -> metric units, 1 -> English units

[replay]
save =0 ; 0 or 1, If set to 1 it will automatically save the full replay at the end of the race
directory = ; the directory where replays will be saved ( must exist )

[event]
track =Lonato ; track ID ( for ex. Lonato )
track_layout = ; track layout ( for ex. Short ). Empty -> Default;
track2=Essay
track2_layout=
category = ; kart category allowed. Empty -> Open; KC1, KC3, KS1

[rating]
class = ; A -> 2000+, B -> 1600-1999; C -> 1200-1599; D -> 800-1199

[weather]
realistic =0 ; 0 or 1, if set to 1, following params are ignored
conditions =0 ; 0 -> sunny, 1 -> cloudy, 2 -> rainy
temperature =17 ; air temperature, celsius
wind_direction = ; 0 -> north, 1 -> north-east, 2 -> east, ..., 7 -> north-west
wind_speed = ; meters/second
track_conditions =0 ; 0 -> dry, 1 -> wet

[hardcore]
force_cockpit =0 ; 0 or 1
no_aids =0 ; 0 or 1
limited_tyre_sets =0 ; 0 or 1

[race]
quick_race =0 ; 0 or 1, if set to 1, practice, sighting lap and warmup lap are skipped
practice_length =5 ; minutes
qualify_length =10 ; minutes
sighting_lap =0 ; 0 or 1
race_length =20 ; % of full length
restart_delay =5 ; server restart time in seconds

JamieP

You may have to make sure that the port forwarding on your router and firewall exception is setup correctly.


JamieP

What operating system is the server running? Make sure the software firewall is also configured. I had this issue as well in the past

VELOCIPEDE


dibu

If you are sure that your router is configured correct then check your  Windows Firewall with Advanced Security   (Administrative Tools)

There has to exist an  Inboud Rule  for the UDP ports you use or for ..\kart.exe on all ports. Also check that you choose the right profile (Domain, Private, Public).
Do the same for the  Outbound Rule .

If you are behind a NAT-router you can also risk to disable the firewall completely for a short test.

I also have it running on server 2008 r2 and no connection problems.

VELOCIPEDE

many many thanks! now all work fine! :-)

VELOCIPEDE

question for all users: can view, enter and drive online into the Drivingitalia dedicated server?
all ok without problem?

dibu

It's visible in the online list with a ping and I could enter it without problems.
I also drove some fun laps until my kart.exe crashed. Seems to be ok now.